Latency issue in US region impacting login, guide delivery and event data processing

Incident Report for Pendo

Update

Guide deliverability, data processing, and logins have been restored. There was no loss of data. There may be a small delay in event processing.
Posted Sep 14, 2026 - 12:22 EDT

Update

We are continuing to monitor for any further issues.
Posted Sep 14, 2026 - 12:18 EDT

Monitoring

We have deployed a fix for a disruption affecting login, guide delivery latency (web and mobile), and event data processing latency in our US environment. Our team is actively monitoring to confirm the behavior is fully resolved and will provide a further update once that's confirmed.
Posted Sep 14, 2026 - 12:14 EDT
This incident affects: US environment (app.pendo.io) (Pendo UI, Guide Deliverability, Mobile Guides, Analytics - Data Processing, Mobile Analytics).