Feedback Latency
Incident Report for Pendo
Resolved
We believe this issue to be completely resolved.

Should any further latency be seen please contact the Pendo Technical Success team.
Posted Oct 29, 2021 - 12:10 EDT
Monitoring
We have seen page loading return to normal times and Feedback is behaving as normal.

We are continuing to monitor and will update this page once we believe the problem to be fully resolved.
Posted Oct 29, 2021 - 10:49 EDT
Investigating
We are noticing latency across the Feedback platform. Pages are taking longer than expected to load.

Pendo Engineering is reviewing the issue and we will provide updates as soon as they are available.
Posted Oct 29, 2021 - 10:23 EDT
This incident affected: Feedback (Feedback API, Feedback UI).