Classic/Legacy Feedback in The US Server is Down

Incident Report for Pendo

Resolved

This incident has been resolved.
Posted Jun 19, 2025 - 05:21 EDT

Investigating

We are currently investigating the issue.
We had a scheduled maintenance window for Feedback in the US this morning.
The upgrade started at around 7 a.m. GMT, but the maintenance is taking longer than expected, and the operation cannot resume.
We are contacting Google Cloud Support to help us unblock the operation and restart the maintenance.
Posted Jun 19, 2025 - 04:54 EDT
This incident affected: Feedback (Feedback API).