NPS Email Backup disabled in US region

Incident Report for Pendo

Resolved

NPS emails have been re-enabled for the US region and the root issue causing the outage has been fully resolved.

All emails that should have gone out during the outage will be released by end of the day Eastern Time.
Posted Jun 18, 2025 - 12:17 EDT

Identified

At approximately 7:25 AM UTC time, our email backup system for delivering emails for NPS was disabled in our US region. We have identified the root cause and are currently working to remediate the issue.
Posted Jun 17, 2025 - 09:21 EDT
This incident affected: Guides (NPS Email).