Event processing delays

Incident Report for Pendo

Resolved

All event processing delays have been caught up. This incident is resolved.
Posted Jul 10, 2026 - 08:35 EDT

Update

We are continuing to monitor for any further issues.
Posted Jul 10, 2026 - 07:13 EDT

Update

All events other than session replay events are back to normal processing latency. We are continuing to make progress on the session replay event backlog.
Posted Jul 10, 2026 - 07:08 EDT

Monitoring

This morning we experienced delays in processing of incoming events. While no events were lost during this time, the delays could have impacted the targeting of guides which rely on page and feature views for eligibility. At this time, we are back to normal processing latency for 90% of customers, and should soon catch up for the rest.
Posted Jul 10, 2026 - 06:45 EDT
This incident affected: US environment (app.pendo.io) (Guide Targeting, Analytics - Data Processing, Session Replay).