Send Update Shows No Recipients in Pendo Listen

Incident Report for Pendo

Resolved

Following testing, we have deployed a fix and email information is now appearing as expected and we consider the issue resolved.
Posted Mar 12, 2026 - 14:07 EDT

Identified

We are currently resolving a technical mismatch between our database and the user interface that is preventing some email information from appearing correctly. A fix is being tested now.
Posted Mar 12, 2026 - 11:28 EDT

Investigating

We are currently investigating an issue where no recipients are found when attempting to send an email update for feedback items or ideas in Pendo Listen. This includes items submitted within the last 30 days.
Posted Mar 12, 2026 - 10:49 EDT
This incident affected: EU environment (app.eu.pendo.io) (Feedback UI), US environment (app.pendo.io) (Feedback UI), and US1 environment (us1.app.pendo.io) (Feedback UI).