Pendo application and CNAME guide delivery outage in EU region

Incident Report for Pendo

Resolved

This incident has been resolved.
Posted May 07, 2025 - 12:33 EDT

Monitoring

At 12:02 UTC (14:02 CET / 8:02 ET), Pendo released an update to our EU region that caused the app to crash for all customers in that region. Around 12:30 UTC, our application crashed for users in the EU region and service was restored by 13:00 UTC.

There was no impact to data collection. However, for our customers using our CNAME product in the EU region, there was a guides outage for approximately 30 minutes. Those services have been restored as of 13:00 UTC and we are currently monitoring behavior.
Posted May 07, 2025 - 09:28 EDT
This incident affected: Pendo UI and Guides (Guide Deliverability).