Data Sync Destination Invalidation Issue for Cloud-Storage Destinations

Incident Report for Pendo

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 08:33 EST

Update

All recurring exports have been re-enabled. Currently, Pendo is working to backfill exports we attempted to deliver from approximately 8:15 AM ET on November 19 to 1pm ET on November 20.
Posted Nov 20, 2025 - 17:38 EST

Monitoring

We have pushed a fix that has corrected the validation issue and Pendo is currently reactivating all incorrectly disabled recurring exports.
Posted Nov 20, 2025 - 12:56 EST

Identified

Starting at approximately 8:15 AM ET on November 19 an issue in our data sync validation checks incorrectly marked all Data Sync Destination Invalidation Issue for cloud-storage destinations as invalid. As a result, impacted customers may have received an email notification stating that their data sync destination was invalid and that recurring exports were disabled.

Pendo has identified the issue and is currently working to push a fix live. This issue did not affect data integrity or existing exported data — only the status and scheduling of ongoing syncs.

Please note that at this time, customers do not need to revalidate their destinations.
Posted Nov 20, 2025 - 10:48 EST
This incident affected: AU environment (app.au.pendo.io) (Other), JPN environment (app.jpn.pendo.io) (Other), US environment (app.pendo.io) (Other), EU environment (app.eu.pendo.io) (Other), and US1 environment (us1.app.pendo.io) (Other).